Share your knowledge, post technical queries or just showcase your passion for your Royal Enfield with like minded folk. Be a part of these discussions or browse through debates packed with loads of information, from the experts themselves in our archives.

sign up login

thread

High Idling RPM , Automatic Revving
  • High Idling RPM , Automatic Revving

    created by: Sanketh08:08 PMMon, January 25, 2016
  • Hi, I am Sanketh from Bangalore. I own a TB500 and its been a year since I got it, I have driven around 8000-9,000 kms so far and the bike was in very good condition until now and I really enjoyed riding my bike around the city. Recently I started hearing a weird ringing noise when I try to accelerate and this went on to increase in the next few days.I have no idea from where the noise is actually coming from.

    In addition to this the idling RPM has increased suddenly from the last week and due to this the vibration has increased and the most weird thing is that after I drive the bike for about 2kms, the bike accelerates by itself when its in gear.

    The bike starts revving by itself when its in gear and When I bring it down to neutral the revving stops but the Idling would be very high. If i put it in gear and let go off the clutch and the brake the bike starts moving even without me accelerating.

    This is making my drive very uncomfortable. I would like to know if any one is facing a similar situation with the increased Idling and Revving. Does anybody know why this might be occurring and how can I get rid of it.

    It would be really helpful if you could help me out from this. Sorry for the long writing.

    Thank you. 


  • Jagan Mohan Rao

    10:21 PM Mon, January 25, 2016
  • Hi, I am Sanketh from Bangalore. I own a TB500 and its been a year since I got it, I have driven around 8000-9,000 kms so far and the bike was in very good condition until now and I really enjoyed riding my bike around the city. Recently I started hearing a weird ringing noise when I try to accelerate and this went on to increase in the next few days.I have no idea from where the noise is actually coming from.

    In addition to this the idling RPM has increased suddenly from the last week and due to this the vibration has increased and the most weird thing is that after I drive the bike for about 2kms, the bike accelerates by itself when its in gear.

    The bike starts revving by itself when its in gear and When I bring it down to neutral the revving stops but the Idling would be very high. If i put it in gear and let go off the clutch and the brake the bike starts moving even without me accelerating.

    This is making my drive very uncomfortable. I would like to know if any one is facing a similar situation with the increased Idling and Revving. Does anybody know why this might be occurring and how can I get rid of it.

    It would be really helpful if you could help me out from this. Sorry for the long writing.

    Thank you. 


    TB 500 fitted with EFI system along with positive crank case ventilation.A small rubber tube running out from valve might have disconnected or cut.Please ensure that it might be in place.

  • Sanketh Ramesh

    10:09 AM Wed, January 27, 2016
  • Thank you Jagan, I will check it out.

  • Ajay Rajpal

    04:48 PM Wed, January 27, 2016
  • Hi

  • Sanketh Ramesh

    12:39 PM Sat, January 30, 2016
  • Hi Ajay.

  • Ramakrishnan Pallipurath

    02:45 PM Fri, February 5, 2016
  • Hi, Malfunction of the EFI, and idling to be checked and to be re-mapped. Further assistance I Might Be Of Help To You, As I Run Own High-Tech Facility CUM Training Centre In-Fact, A Laboratory Too) In Maraimalai Nagar, Chennai Exclusively For RE Machines. Write To Me At (Pallipurath2009@Gmail.Com) Thank You, P Ramakrishnan B-Tech Mechanical Engg From NIT / REC +91-9841759591 (Pallipurath2009@Gmail.Com)

  • abhay ramesh

    07:20 PM Fri, May 6, 2016
  • Hi Sanketh, I am also facing the same issue of Auto reving and ringing sound at higher RPM. Very curious to know whether you were able to get it corrected? Thanks, Abhay (abhayramesh@gmail.com)

  • abhay ramesh

    07:29 PM Fri, May 6, 2016
  • Hi Jagan, One of the mechanic also told, the tube might have got disconnected and that is the reason why my D.strom is reving automatically. It will be of great help if you could please tell me which tube are you talking off. Thank you